Froyo Required for Facebook Update

Anyone that has the Facebook app probably has nothing nice to say about it considering the amount of time it takes to do just about anything.  With promises to make nice by delivering a faster, capable version the app is now requiring Android 2.2 Froyo or higher.  Other improved features include “front-facing camera support, a new messaging feature that lets you hop between conversations and share photos, plus other bug fixes and a security improvement”.  All of this sounds nice but we won’t hold our breath when it comes to Facebook’s reputation for apps.

 

 

Android Central

 

 

Tags: , ,